Comment désactiver les documents récents dans Unity?

58

Comment puis-je désactiver le suivi et l’affichage des fichiers récemment ouverts (et d’autres éléments mémorisés) dans une installation par défaut d’Ubuntu? (Cette question concernait à l'origine 11.10, mais maintenant que je suis le 12.04, c'est la réponse que j'ai sélectionnée.)

(Notez qu’il ne s’agit pas d’une copie de Comment puis-je empêcher l’apparition de fichiers récents dans Unity? , car question et ses réponses concernent le filtrage temporaire et spécifique, je veux le désactiver complètement pour un compte utilisateur unique.

Ok, pour éviter l’inévitable et développer ma motivation ...

Tout en parcourant les forums habituels et les résultats Google pour une solution, il semble (sans surprise) que les cas d’utilisation quasi universels de cette requête soient Navigation dans le porno ou Recherche sur Warhammer . Et la solution évidente à cela est de créer un autre compte utilisateur contenant toutes les preuves.

Cependant, ce n’est pas la raison pour laquelle je pose la question, et je ne dis pas cela pour que tout soit clair et puissant, parce que cette réponse n’aidera pas. (Même si je ne suis vraiment pas intéressé par Warhammer, et je n'ai aucune idée de la façon dont ce pot de peinture et cette brosse se sont retrouvés dans mon tiroir, non, je ne colle pas mon pouce, etc.) / p>

Mon cas d'utilisation réel est que j'utilise mon ordinateur portable personnel pour des présentations dans différents milieux de ma vie. J'ai un compte utilisateur configuré avec tous les paramètres que j'aime pour les présentations (raccourcis, petit lanceur, associations par défaut, etc.). Mais je ne veux pas qu'une frappe accidentelle (ou la boîte de dialogue de recherche) affiche d'autres présentations récentes que j'ai présentées ou les fichiers que j'ai utilisés pour composer la présentation, etc. Je ne veux pas non plus avoir à recréer ce profil pour chaque présentation que je pourrais donner. Je veux juste un joli petit coin isolé, sans mémoire, propre de mon cahier pour l'affichage public.

    
posée detly 04.01.2012 - 12:02
la source

6 réponses

68

Allez à System Settings et choisissez Privacy .

Ensuite, désactivez le bouton en regard de Activité d'enregistrement . Désormais, vos documents récents ne seront plus enregistrés par Zeitgeist.

    
réponse donnée jokerdino 18.02.2012 - 10:22
la source
1

J'ai trouvé cette solution dans les ubuntuforums du commentaire n ° 3, mais je ne sais pas si cela fonctionne. Essayez-le:

lien

    
réponse donnée heiko81 04.01.2012 - 13:01
la source
1

pour tout document que vous ne souhaitez pas voir sous l'onglet Documents récents; procédez comme suit:

  1. Assurez-vous de conserver tous ces fichiers dans un dossier.
  2. Après y avoir accédé à chaque fois, renommez simplement le dossier.

juste en renommant le dossier que vous verrez le travail magique:)

    
réponse donnée Ketan Deshmukh 09.06.2012 - 17:58
la source
1

renommez ~/.local/share/recently-used.xbel file (par exemple recently-used.xbel-- ) et créez un dossier vide et nommez-le recently-used.xbel dans le même dossier. C'est tout.

    
réponse donnée Chengaver Hero 20.11.2014 - 14:13
la source
0

Vous pouvez désactiver l’enregistrement vidéo dans les paramètres, la confidentialité et les fichiers. Vous pouvez également indiquer à Ubuntu quels dossiers ne doivent pas être enregistrés.

    
réponse donnée vivo 20.12.2012 - 11:45
la source
0

Si vous avez déjà effectué la mise à niveau vers 12.10, faites ceci:

allez à: Paramètres système / Confidentialité / Fichiers

cochez ensuite: Vidéo et Image

vérifiez si cela vous aide si vous souhaitez toujours que votre activité txt et docs soit disponible.

EDIT: Également, il est encore préférable d’utiliser l’option "Ne pas enregistrer d’activité dans les dossiers suivants:" quelle est la meilleure personnalisation que je puisse voir :), peut-être est-il temps de mise à niveau vers 12.10: D

    
réponse donnée Aquarius Power 13.06.2013 - 21:44
la source

Lire d'autres questions sur les étiquettes