Questions avec tag 'gcc'

4
réponses

Comment utiliser le dernier GCC sur Ubuntu?

Je veux compiler mon programme avec la dernière version de gcc . Ubuntu 14.04 est fourni avec gcc 4.8.2, mais il existe 4.9.0, de plus, je vois qu'il est disponible en paquet: gcc-4.9 . J'ai essayé de l'installer sudo apt-get install...
posée 16.05.2014 - 03:11
7
réponses

Obtenir + installer gcc / g ++ 4.9 sur Ubuntu? [dupliquer]

Comment installer la dernière version de gcc et g ++? J'utilise une variété de fonctionnalités C ++ 11 et C ++ 1y; c'est pourquoi j'ai besoin de ça.     
posée 02.03.2014 - 04:05
6
réponses

GLIBCXX_3.4.20 non trouvé, comment corriger cette erreur?

J'essaie de lancer le programme Editeur de mise en page (disponible sur ce site ) sur Ubuntu 14.04.1 64 bits LTS J'obtiens la sortie suivante dans le terminal: $ layout layout: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version 'GLIBCXX_3.4....
posée 19.01.2015 - 21:36
2
réponses

Comment installer gcc-4.8

J'ai vérifié la version de gcc sur mon système. Il est actuellement à 4.6.3. J'ai lu que gcc-4.8 est sorti. J'ai essayé les commandes suivantes sans succès: sudo apt-get install gcc (gcc is already the newest version) sudo apt-get instal...
posée 22.03.2013 - 23:25
4
réponses

Comment installer gcc 4.7?

Je souhaite installer gcc 4.7 pour pouvoir utiliser certaines fonctionnalités de c ++ 11. J'ai téléchargé la source, j'ai lancé ./configure et on m'a dit que j'avais besoin de GMP. Téléchargé le code pour cela, a frappé ./configure et o...
posée 15.03.2012 - 19:06
3
réponses

«erreur fatale: openssl / opensslv.h: aucun fichier ou répertoire de ce type» lors de la compilation de mitmproxy

J'essaie d'installer le paquet mitmproxy via pip comme ceci: $ sudo pip install mitmproxy Il se termine avec le message d'erreur suivant: x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing...
posée 11.07.2016 - 13:53
3
réponses

Installer gcc sur Ubuntu 12.04 LTS

Lorsque j'essaie d'installer gcc sur Ubuntu 12.04 LTS Server avec apt-get install gcc , j'obtiens l'erreur suivante: The following packages have unmet dependencies: gcc : Depends: cpp (>= 4:4.6.1-2ubuntu5) but it is not going to be insta...
posée 22.06.2012 - 02:49
2
réponses

Comment compiler pour ARM?

Comment configurer GCC pour la compilation croisée pour le processeur ARM? L'hôte serait sur x86_64 (AMD64 - Ubuntu 12.04) et la cible serait ARM (Raspberry Pi ainsi que Pandaboard - fera des compilations séparées pour chacun)?     
posée 02.02.2013 - 21:00
2
réponses

Comment installer clang ++?

J'ai du mal à faire fonctionner clang ++ car je compile mon code. Plus précisément, j'obtiens une erreur make: clang++: Command not found . J'ai exécuté sudo apt-get install llvm , ainsi que sudo apt-get install build-essential et sud...
posée 10.08.2014 - 02:54
2
réponses

Comment installer et utiliser gcc 6 sur xenial? [dupliquer]

Je souhaite tester les logiciels existants avec gcc 6, pour s’assurer qu’ils fonctionneront lors de la transition. Comment installer gcc 6? Y a-t-il un ppa disponible? Puis-je faire un "CC = gcc-6 make"? Merci     
posée 15.03.2016 - 17:32