Questions avec tag 'glib'

1
réponse

glib.h fait une erreur. erreur fatale: glib.h: Pas de tel fichier ou répertoire

pour la solution que j'ai recherchée sur Internet. J'ai ajouté le résultat de la commande pkg-config --cflags glib-2.0 c'est -I/usr/include/glib-2.0 -I/usr/lib/i386-linux-gnu/glib-2.0/include au fichier de création comme GCC = -I /...
posée 30.01.2015 - 07:53
1
réponse

Comment compiler un programme helloworld GLib?

Je ne peux pas compiler ce code sous Ubuntu 11.10 pendant qu'il compile normalement sous Ubuntu 10.04: #include <stdio.h> #include <glib.h> int main(int argc, char** argv) { GList* list = NULL; list = g_list_append(list,...
posée 25.12.2011 - 11:11
3
réponses

"ImportError: aucun module nommé glib" lors de l'exécution de ScreenFetch

Lors de l'ouverture du terminal, j'obtiens les 4 lignes suivantes avant que ScreenFetch ne s'exécute: [[ ! ]] Traceback (most recent call last): [[ ! ]] File "/usr/bin/unity", line 21, in <module> [[ ! ]] import glib [[ ! ]] Import...
posée 12.12.2015 - 12:38
2
réponses

Comment résoudre une ancienne erreur GLIB

Je suis en train d’installer GTK + mais il a besoin de plusieurs prérequis. Ce sont glib - 2.0 & gt; = 2.35.3 atk - & gt; = 2.7.5 Pango- & gt; = 1.32.4 gdk-pixbuf-2.0 & gt; = 2.27.1 Maintenant, j'ai mis à niveau ma glib-2.0 vers 2.3...
posée 20.02.2014 - 23:05
1
réponse

Qu'est-ce qui cause les erreurs de glib critique (lors du codage à l'aide du menu de messagerie)?

Si je lance le code python ci-dessous (presque entièrement depuis cet article de blog utile ), je reçois alors trois messages d’erreur identiques à la recherche dans le terminal. Qu'est-ce qui pourrait les causer? Je note que le nombre (5857...
posée 15.03.2011 - 23:13
2
réponses

Komodo Edit: GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' a échoué

quand j'essaie de lancer Komodo Edit 8.0 depuis le terminal, cela me renvoie cette erreur: (process:9508): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed comment puis-je résoudre ce problème? remarque: néanmo...
posée 21.07.2013 - 22:46
1
réponse

Ubuntu 16.04 GLib-GIO-Message: Utilisation du backend GSettings 'memory'. Vos paramètres ne seront pas enregistrés ou partagés avec d'autres applications

Je continue à recevoir cette erreur. Je ne suis pas sûr de savoir comment m'en débarrasser. J'utilise des pilotes NVIDIA 381.22 est-ce que cela cause ce problème? J'ai tout essayé à partir d'ici: Mon installation dconf / gsettings est cassée...
posée 18.05.2017 - 08:28
2
réponses

comment corriger glib-2.35.x 'g type_init est obsolète' erreur lors de la compilation à partir de la source

Salut, j'essaie de compiler gnome-packagekit depuis la source git://git.gnome.org/gnome-packagekit et quand j'essaie et make j'obtiens l'erreur ci-dessus error: ‘g_type_init’ is deprecated (declared at /usr/local/include/glib-2.0/gobject...
posée 01.03.2013 - 07:14
2
réponses

L'installation de glib donne "Vous devez soit avoir le support de gettext"

J'essaie d'installer glib-2.37.6 (également le même problème avec glib-2.32.1 ) et d'obtenir cette erreur lors de la configuration:    Vous devez avoir soit le support de gettext dans votre bibliothèque C, soit utiliser le   Bibliothèque...
posée 29.08.2013 - 02:18
0
réponses

Comment résoudre l'ancienne erreur GLIB lors de l'installation de "pygobject" en utilisant jhbuild

J'essaie d'installer pygobject en utilisant jhbuild . Et je reçois cette erreur: configure: error: Package requirements (glib-2.0 >= 2.48.0) were not met: Requested 'glib-2.0 >= 2.48.0' but version of GLib is 2.38.2 J'ai donc ins...
posée 13.04.2016 - 14:46