Questions avec tag 'php7'

2
réponses

Impossible d'installer php7.0-imap

J'utilise Ubuntu 16.04.1, j'ai installé php7 en août, mais aujourd'hui j'ai essayé d'installer l'extension IMAP et cela ne me laisse pas tomber. [email protected]:/etc# apt-get install php7.0-imap Reading package lists... Done Building dep...
posée 15.11.2016 - 16:45
1
réponse

HTML ne s'affiche pas dans le navigateur

Utiliser un site basé sur ZF2. /var/www/html/app est root et contient des dossiers de modules avec vues et public. Exécution de /var/www/html/app/public via : 'php -S 0.0.0.0:8080 -t public/ public/index.php' Le site se charge bi...
posée 09.02.2017 - 19:03
1
réponse

La dernière mise à jour désactive php7 pour apache2 [fermé]

Faites-moi savoir quels journaux vous avez besoin pour résoudre ce problème. [email protected]:/etc/apache2/mods-enabled# uname -v #19-Ubuntu SMP Wed Oct 11 18:33:49 UTC 2017 [email protected]:/etc/apache2/mods-enabled# [email protected]:/...
posée 05.11.2017 - 18:47
2
réponses

PHP7 sur Ubuntu 12.04

J'aimerais mettre à jour notre version de production php vers la nouvelle version de php7. Malheureusement, nous sommes actuellement en cours d'exécution sur Ubuntu 12.04. J'ai déjà essayé d'installer php7 sur la machine virtuelle correspondante...
posée 19.04.2016 - 13:50
3
réponses

Erreur: Le nouveau fichier /usr/lib/php/7.0/php.ini-production.cli n'existe pas!

Après avoir mis à jour mon système, j'ai reçu cette erreur: Setting up php7.0-cli (7.0.5-1+deb.sury.org~trusty+1) ... Error: The new file /usr/lib/php/7.0/php.ini-production.cli does not exist! No apport report written because the error messag...
posée 31.03.2016 - 20:16
0
réponses

Ubuntu 17.10 Utiliser PHP7.0 au lieu de PHP7.1

J'ai php7.1 et php7.0 installés sur mon Ubuntu 17.10 . Lorsque je tape php -v , le résultat affiche PHP 7.1.8-1buntu1 (cli). Cependant, j'ai un projet qui ne supporte pas php 7.1, donc je dois le faire passer à php 7.0. J'ai essayé ce qui...
posée 13.11.2017 - 11:51
0
réponses

Quelle est la combinaison sécurisée de la configuration de php.ini et du code PHP pour vérifier SSL / TLS sur Ubuntu 14.04?

J'utilise PHP 7.0 de ppa:ondrej/php sur Ubuntu 14.04. J'interagis avec une API et je voudrais m'assurer que mon code PHP / CURL interagit avec le bon serveur et en toute sécurité (sans risque de surveillance, de MITM, d'altération, etc.)....
posée 21.07.2017 - 00:09
0
réponses

Comment installer php7-fpm avec Apache sur Ubuntu 16.04 avec des vhosts personnalisés .ini et chrootés?

Après plusieurs problèmes de sécurité, j'ai décidé de refaire complètement la configuration de mon serveur sur l'hébergement mutualisé car j'ai besoin de vhosts pour utiliser des fonctions telles que exec et d'autres pour Wordpress. J'ai déci...
posée 09.07.2017 - 09:55
0
réponses

Impossible d'installer Xdebug (dépendances non satisfaites: php7.1-dev libssl-dev libssl1.0.0)

J'essaie d'installer Xdebug sur Ubuntu Zesty (17.04), mais j'ai du mal à résoudre les dépendances. Je suis les instructions de cette url: lien Point 4. il est dit "Exécuter: phpize (Voir la FAQ si vous n'avez pas de phpize." Quand je...
posée 21.05.2017 - 20:39
1
réponse

downgrade PHP 7.1 vers PHP 7.0

J'ai un serveur Ubuntu 16.04 qui exécute nginx + PHP7.1.2. J'ai un script PHP qui est exécuté par un cronjob, il donne quelques problèmes de compatibilité (en PHP 7.0, il fonctionne parfaitement et d'autres personnes ont le même problème), donc,...
posée 24.02.2017 - 20:27