Questions avec tag 'pip'

3
réponses

apt-get install vs install pip

Je suis un peu perplexe quant aux cas dans lesquels les commandes ci-dessus doivent être utilisées lors du téléchargement de paquets Python. J'essayais de télécharger un paquet nommé pyudev conformément à une réponse avec cette question . J'ai...
posée 09.03.2014 - 16:51
5
réponses

Comment détecter et supprimer les paquets Python installés via pip?

J'ai accidentellement installé des paquets Python sur mon système en utilisant pip au lieu de apt-get . Je l'ai fait de deux manières: en utilisant une version plus ancienne de virtualenv, j'ai oublié d'ajouter --no-site-packages lor...
posée 08.08.2012 - 10:48
3
réponses

Erreur lors de l'installation de scrapy dans virtualenv à l'aide de pip

pip install scrapy Downloading/unpacking scrapy Downloading Scrapy-0.24.2-py2-none-any.whl (502kB): 502kB downloaded Downloading/unpacking pyOpenSSL (from scrapy) Downloading pyOpenSSL-0.14.tar.gz (128kB): 128kB downloaded Running setup.py...
posée 19.07.2014 - 02:26
3
réponses

«erreur fatale: openssl / opensslv.h: aucun fichier ou répertoire de ce type» lors de la compilation de mitmproxy

J'essaie d'installer le paquet mitmproxy via pip comme ceci: $ sudo pip install mitmproxy Il se termine avec le message d'erreur suivant: x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict-aliasing...
posée 11.07.2016 - 13:53
2
réponses

installer pip3 (pour python3) sur Ubuntu 16.04 LTS en utilisant un proxy

J'ai essayé d'entrer: sudo apt install python3-pip L’erreur que j’obtiens est: $ sudo apt install python3-pip Reading package lists... Done Building dependency tree Reading state information... Done The following additional pa...
posée 27.05.2016 - 05:48
5
réponses

Comment mettre à niveau pip au plus tard?

J'ai installé pip en utilisant get-pip.py après que pip freeze jette en dessous de l'erreur Exception: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main status = se...
posée 22.12.2015 - 12:27
4
réponses

Comment installer la dernière version de pip lorsque j'ai déjà installé celui fourni par Ubuntu?

Dans Ubuntu 16.04 quand vous faites: pip install --upgrade pip vous obtenez: Collecting pip Using cached pip-8.1.2-py2.py3-none-any.whl Installing collected packages: pip Successfully installed pip-8.1.1 You are using pip version 8.1.1,...
posée 22.05.2016 - 16:57
3
réponses

Comment installer des paquets avec pip lorsqu'il existe plusieurs versions de Python?

J'ai différentes versions de python installées, python 2.7 étant la version par défaut et 3.2 la seconde. Maintenant, je veux installer pyramide à l'installation 3.2. Comment puis-je faire ceci? Le simple fait d'utiliser pip pour installer la...
posée 15.02.2012 - 20:18
5
réponses

Lors de l'utilisation de sudo pour exécuter pip "pip: commande not found" mais il est installé

sudo easy_install pip Searching for pip Best match: pip 1.4.1 Processing pip-1.4.1-py2.7.egg pip 1.4.1 is already the active version in easy-install.pth Installing pip script to /home/nyzlfc/.local/bin Installing pip-2.7 script to /home/nyz...
posée 17.11.2013 - 13:31
6
réponses

pip ne fonctionnera pas. jette des erreurs à la place

Je rencontre des problèmes chaque fois que je lance pip avec des arguments ou des indicateurs. J'ai essayé de faire apt-get install --reinstall python-pip mais cela ne m'aide pas et je ne sais pas comment résoudre ce problème Versio...
posée 14.12.2014 - 20:22